web analytics

SynAdvCFG – Syndicate Advanced Config Tool v0.2.1

SynAdvCFG – Syndicate Advanced Config Tool v0.2.1

Beta Release – Use with Caution

Written by Nigel Todman ([email protected])

Updates: http://nigelt.wordpress.com/

CRC32/SynAdvCFG.exe/95812FBA

Download v0.2.1 (Beta Release)
Discuss on Official Starbreeze Forums
Discuss on WideScreenGamingForum.com
StrategyInformer.com

Changelog
———
v0.2.1 04-13-12
Automatic settings path detection is now optional!
Fixed settings path detection for Windows XP!
Added BitCoin address! Donations welcome but not required 🙂
(Click on BitCoin to copy address to clipboard)
Various code optimizations

v0.2.0 03-22-12
Added Launch Syndicate.exe function!
Increased delay for detection of username for settings path
Various code optimizations

v0.1.3 03-20-12
Really Fixed subscript out of range this time
Various code optimizations

v0.1.2 03-20-12
Fixed subscript out of range when saving settings
Various code optimizations

v0.1.1 03-19-12
Added support for saving settings! Use with caution!
Added support for detection/writing of Brightness
Added support for detection/writing of Black Level
Added support for detection/writing of Pixel Aspect
Rearranged interface items slightly
Resized main application window
Various code optimizations

v0.1.0 03-10-12
First release
Attempts to automatically detect settings folder
Parses values from Environment.cfg
Read Only, No write functions yet!

Download v0.2.1
Download v0.2.0
Download v0.1.3
Download v0.1.2
Download v0.1.1 (Beta Release, Write functions Enabled!)
Download v0.1.0 (Debug Release, Read Only)

 

webmaster

 

13 thoughts on “SynAdvCFG – Syndicate Advanced Config Tool v0.2.1

  1. Doesn’t work for me. Win7 x64. All I want to do is change the resolution, but it always tells me “Run-time error ‘9’: Subscript out of range”. Tried running it from desktop as well as in Syndicate folder. Tried running as admin. I’ve tried changing my Environment.cfg manually but even its a little wonky (Where the H and W dimensions should be there are just 0’s). Game runs fine, just cant get it to 1360×768 where I want it.

  2. When clicking save. Opening the program and clicking Environment within the GUI works fine, it loads the specs that the game has. It’s after trying to click save, and after saying it’s saving a backup, that the message appears. Then the whole thing closes out.

  3. Just tried it, and again the same error 🙁 I still can’t figure out where its getting the values from though, because they match up with the in-game settings, but not whats in the environment.cfg file. The one in question is located at Program Files (x86)EA GamesSyndicate, right?

  4. I’m also not sure where the backup save file is going. Maybe the issue is there, before actually replacing the settings and saving?

  5. Well, In my case its C:UsersAdministratorDocumentsSyndicate

    Also you sure you got the new v0.1.2 ? I still havent been able to recreate the error.

  6. Ahh, I guess there’s a .cfg there too and thats the one I needed to change. Random one in game install directory I guess? Anyways, I used 0.1.2 and still had the issue. I moved it into documentssyndicate folder and tried there, but still had the issue.

  7. Almost positive I’ve fixed it for v0.1.3 😛 I was able to recreate the error by making my Environment.cfg shorter, Some of the array lengths were set based on the length of your config file. So now i made the array lengths bigger then would ever be required and no longer base it on the length of the file in that instance…Pretty sure that will fix it this time.

Leave a Reply

Your email address will not be published. Required fields are marked *